Adrian Flux - 01553 845 945

Mitsubishi Delica Owners Club UKô
Mitsubishi Delica L300, L400 and D:5 Owners Club
 
 FAQFAQ   SearchSearch   Watched TopicsWatched Topics   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your personal messagesLog in to check your personal messages   Log inLog in 
CalendarCalendar  dynamic online chat serviceChatrooms   Delica Club ShopClub Shop  MDOCUK Classified Ads serviceClassified Ads
MDOCUK home pageMDOCUK Home  Yellow Diamond ClubsYellow Diamond Clubs  Delica Club (CA)Delica Club (CA)  Delica Club (AUS)Delica Club (AUS)

rear screen washer not functioning


 
Post new topic   Reply to topic    Mitsubishi Delica Owners Club UKô Forum Index -> General non-technical
View previous topic :: View next topic  
Author Message
slowood



Joined: 11 May 2019
Posts: 8
Location: Luton, Bedfordshire

PostPosted: Fri May 17, 2019 11:58    Post subject: rear screen washer not functioning Reply with quote

i've filled it with screen wash solution but when the rear washer is activated nothing comes out. Sometimes some spit.

Am i misssing something here?
Back to top
View user's profile Send personal message
Google
Sponsor





PostPosted: Fri May 17, 2019 11:58    Post subject: Google Ads keep this community free to join!


Back to top
andyman



Joined: 08 Dec 2012
Posts: 4172
Location: Penrith, Cumbria

PostPosted: Fri May 17, 2019 22:36    Post subject: Reply with quote

Have you cleaned out the jet  with a pin or wire brush bristle?
_________________
Andy C L300 Super Exceed - over 100 smiles per gallon!
Back to top
View user's profile Send personal message
slowood



Joined: 11 May 2019
Posts: 8
Location: Luton, Bedfordshire

PostPosted: Sun May 19, 2019 20:27    Post subject: Reply with quote

andyman wrote:
Have you cleaned out the jet †with a pin or wire brush bristle?
The actual jet? no not yet. Will try.
Back to top
View user's profile Send personal message
Tricks



Joined: 25 Aug 2018
Posts: 19
Location: Milton Keynes

PostPosted: Wed Sep 11, 2019 8:40    Post subject: Reply with quote

Had the same on my front washers, first drivers then passenger side stopped working over a few days. Pump was fine so took out the jets. Had to dunk in a cup of hot water for five minutes and poke with a paper clip.
They are better.
Back to top
View user's profile Send personal message
Deker
Lifetime member
Lifetime member


Joined: 08 Mar 2008
Posts: 3323
Location: Borehamwood Hertfordshire

PostPosted: Wed Sep 11, 2019 20:41    Post subject: Reply with quote

Also try Hydrochloric Acid - removes "Limescale"
Available from cleaning suppliers. But it is usually diluted  Sad

Works well in toilets too  Smile  That is what you tell your supplier - If asked.

Mr D
_________________
You can take me anywhere twice. - - - - - Once to apologise :-(

No trees were harmed in the sending of this message but millions of electrons were terribly inconvenienced.
Back to top
View user's profile Send personal message
Display posts from previous:   
Post new topic   Reply to topic    Mitsubishi Delica Owners Club UKô Forum Index -> General non-technical All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


All contents © Hobson's Choice IT Solutions Ltd 1997 on
Powered by phpBB © 2001, 2005 phpBB Group